Oliver + S

Long shot – anyone know what's wrong with my machine?

Viewing 8 posts - 1 through 8 (of 8 total)
  • LINK
    claireabel @claireabel

    Not sure if this is the right place to post this, but here goes.

    My sewing machine keeps breaking (cue stamping of feet and tears of frustration).

    This is a video of the problem: http://www.flickr.com/photos/39113615@N06/4981405555/

    In a nutshell:

    * it has happened numerous times, and was serviced less than 2 weeks ago (the Janome dealer couldn’t find the problem, but the service seemed to temporarily fix the issue)

    * it happens regardless of which foot or stitch I use

    * I have tried changing the bobbin (I am using the official Janome bobbins)

    * I have tried re-threading

    * It happens regardless of the thread or fabric I use.

    Waahhh!!! So frustrated! I really want to do the jump-rope sewalong, but cannot sew at the moment. And I have quite a few projects on the go I need to complete (eg, for a baby shower this weekend).

    I’m going back to the dealer tomorrow, but was wondering if anyone else had experienced similar with their machine. (It looks like a bobbin issue but not sure what exactly?)

    It is a Janome DC3050 and only a year old.

    (Off to sulk)

    LINK
    icicle @icicle

    Something to try while you wait: have you tried cleaning out the bobbin area? It might be lint or loose threads.

    LINK
    Lizabeth @Lizabeth

    Two guesses to try:

    1) change the needle (I don’t think this was listed as one of your attempted fixes… forgive me if you have tried this!)

    2) there should be a way to unscrew the metal plate–take this off, remove the bobbin, and remove the bobbin casing (the black or silver shell shaped tray thing the bobbin sits in). take a qtip lightly dipped in rubbing alcohol and clean out under that bobbin casing. it is incredible how much gunk can get under there. also, while you are cleaning, double check that there aren’t any wads of bobbin thread (look around behind the feed dogs especially).

    when you put the shell shaped tray back in it can be a bit finicky–don’t panic! just keep gently wiggling it till it drops back into place.

    I think watching the video, that perhaps the bobbin tail is getting caught. thread the bobbin very carefully (on many machines the tail is to be slid under/against the side wall of the casing); and before you start sewing, turn the wheel towards you to draw up the bobbin tail–carefully pull both the bobbin tail and needle thread towards the back of the machine a little ways, take a deep breath, place your fabric, and hopefully it will work 🙂

    LINK
    etc3 @etc3

    Hi there,

    My Janome does something similar if I forget to hold the thread tails at the back when I start to sew.

    LINK
    Rpankow @excytin

    Oh Claire, I feel your pain!! Why do those sort of things seem to happen when you have to get things done? I agree with Lizabeth and etc3. I have a Janome as well and when I run into the same problem when I don’t have enough tail and get a hold of it. I also have come to notice that I do get lint build up rather quickly, way more than I would expect, especially after sewing one little garment of corduroy. I hope that you get things figured out soon! Please keep us posted, I’m sure we’ve all been there.

    LINK
    JohannaO @JohannaO

    Mine is an older Janome, but it will do that if I miss a step in the re-threading process. Good luck.

    LINK
    claireabel @claireabel

    Thanks everyone

    I didn’t know I had to hold the thread tails! I am still a bit of a beginner – you learn something everyday.

    I followed everyone’s advice and (drumroll) it’s working!!! I suspect maybe it was the needle? When i read your post Lizabeth I remembered that I hit a pin about an hour before the problem occurred.

    Thank you everyone, and sorry for being a bit thick. Hopefully I’ll have some more stuff to add to the Flickr group before too long.

    Claire

    LINK
    nancy @dollfancier

    Excellent answers!!! this is such a supportive community. xoxo, Nancy

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

copyright

Unless otherwise credited, all work on this blog is © Liesl + Co., Inc, 2008-2017. You are welcome to link to this blog, but please ask permission before using any text or images.